2 заметки с тегом

espeasy

Влажность в квартире

Собрал мини-метеостанцию для зала (планирую установить подобные во все комнаты квартиры), подключил её к Domoticz. Получилось отлично — сама станция размером со спичечный коробок, нужно только подобрать ей корпус.
Показания поначалу ввели в ступор: давление около 1000 и влажность около 20%. Залез в документацию, оказалось что давление датчик измеряет в гПа. Пришлось в прошивке ESP8266 создавать еще один виртуальный датчик и пересчитывать для него показания в мм ртутного столба. Всё таки в России используется такая единица измерений. А вот с влажностью непонятно до сих пор. Текущие показания — 17%, хотя норма составляет 40-50%. Поначалу думал, что что-то с датчиком. Распаковал новый, установил — картина не изменилась. Сейчас на работе вспомнил об этом, подключил AM2302 — тоже около 18%. Хоть на улицу выноси! Пришлось пойти на сайт narodmon.ru. Там картина поинтересней — показания колеблются от 14% до 24%. Хм, ладно, допустим, что все используют одно и то же оборудование. В таком случае нужно обратиться к более официальному источнику. Но «официалы» показали примерно ту же картину — от 20% до 30%.
В общем, пока что можно успокоиться и провести несколько экспериментов по её повышению, вроде кипящего рядом чайника.

Показания барометра
Показания барометра
Виртуальный датчик
Виртуальный датчик

Новые ESP8266

Дней 10 назад полностью пришел мой заказ: 10 ESP8266 12E, 10 плат-адаптеров для них и 20 штук регуляторов напряжения HT7833 с нужной распиновкой. Первым делом, конечно, решил собрать пару штук. Регуляторы по размеру оказались чуть меньше, чем контакты под них на адаптере, но это полбеды. Чуть больше припоя — и все замечательно. Пайка ESP тоже проблем не вызвала. А вот включение этой сборки меня напрягло — регуляторы ощутимо «жарили». Пробовал другой источник питания — картина не менялась. Напряжение на входе было стабильно низким и его явно не хватало для запуска модуля. Вроде бы и проверял все на несколько раз, но все равно оставалось непонятным такое их поведение. Решил отложить пока в сторону, ибо были и другие задачи.
Сегодня, когда появилось свободное время, решил вернуться к этому вопросу. Смахнул с платы регулятор, впаял перемычку и... На мое удивление все заработало в штатном режиме. Питание не проверял. Взял еще один набор, собрал без HT7833, подал 3.3 вольта. Все работает. Хм... Вернулся к предыдущему, припаял новый HT7833, подал питание. Регулятор не грелся, ESP-ха приветственно мигнула индикатором WiFi, типа «привет, хозяин». Погоняв модуль несколько минут, единственным вариантом почему у меня они грелись в последний раз осталась переполюсовка. Может быть, меня тогда «перемкнуло»?
Запустил прошивку модуля. Тут во весь «рост» стала другая проблема. Оказалось, что «ноги» для адаптера имеют чуть меньший диаметр, чем нужно. Вследствие чего у меня наблюдался крайне нестабильный контакт. Но как-то обошел этот момент и удалось залить прошивку ESPEasy. Подключился к модулю, посмотрел информацию. Вроде бы все нормально. Но что-то не давало покоя... После прошивки третьей микросхемы и промотра информации о ней, понял — по документации в этих модулях 512 Кб памяти, а прошивка мне показывает, что реальный размер — 4 Мб. Да это же мне позволяет обновляться через OTA!!! Скачал более свежий релиз прошивки и пошел накатывать на все модули, которые успел спаять.